読者です 読者をやめる 読者になる 読者になる

homebrew+rbenv+ruby-buildでRuby2.1.0をインストールしようとしたけどうまくいってないという話

まずはrbenvでインストールできるバージョンを確認する

$rbenv install -l

f:id:alice345:20131226162709j:plain

あれ,2.1.0の正式リリース版が見当たらない...すると

というアドバイスを頂いたので,ruby-buildを更新する.

$brew upgrade ruby-build

f:id:alice345:20131226163344j:plain

入れてたつもりだったけども,インストールしていなかったみたい...?
ということで再インストール.

$brew install ruby-build

そしてインストールできるRubyのバージョンを確認

$ruby-build --definitions 

f:id:alice345:20131226163745j:plain

いない...
homebrewのほうのバージョンアップからやり直してみる.

$brew update
$brew upgrade ruby-build
$ruby-build --definitions

f:id:alice345:20131226171224j:plain

2.1.0が見えた!rbenvのほうでもやってみるとなぜか2.1.0が見えない!?!?!?!

もうよくわからないので,もう一回最初から試してみる

続く...