読者です 読者をやめる 読者になる 読者になる

RVMを使ってRuby2.0.0にバージョンアップしてみた

今まで1.9.3を使っていたので,2.0.0を導入してみた.(すごい今更)
次のバージョンアップも同じ手順でやると思うので忘れないようにメモ.

導入する際にはRVMを使った.まず導入できるバージョンの確認.
$rvm list known

# MRI Rubies
[ruby-]1.8.6[-p420]
[ruby-]1.8.7[-p371]
[ruby-]1.9.1[-p431]
[ruby-]1.9.2[-p320]
[ruby-]1.9.3-p125
[ruby-]1.9.3-p194
[ruby-]1.9.3-p286
[ruby-]1.9.3-p327
[ruby-]1.9.3-p362
[ruby-]1.9.3-p374
[ruby-]1.9.3-p385
[ruby-]1.9.3-[p392]
[ruby-]1.9.3-head
[ruby-]2.0.0-rc1
[ruby-]2.0.0-rc2
ruby-head

2.0.0がインストールできることを確認.2.0.0をインストールする場合は
$rvm install 2.0.0
するとこんな画面が

f:id:alice345:20130730105518j:plain

成功したかどうか確認.
$rvm list

=> ruby-1.9.3-p392 [ x86_64 ]
 * ruby-2.0.0-rc2 [ x86_64 ]

# => - current
# =* - current && default
#  * - default

 

2.0.0がインストールされていることを確認.このままだとdefaultが1.9.3なのでdefaultを2.0.0に変更する.
$rvm --default 2.0.0
ターミナルを再起動して,再度rvm listで見てみると

   ruby-1.9.3-p392 [ x86_64 ]
=* ruby-2.0.0-rc2 [ x86_64 ]

defaultが変更できていることを確認.めでたし.